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eXpressDSP Host Tools Provide an Integrated
Development Environment
• Code Composer Studio™ IDE Development Tools – a powerful set

of integrated development tools that can be enhanced with TI and
third-party plug-ins. With all these tools in one integrated environment,
CCStudio boosts your effectiveness and productivity.

Code Composer Studio (CCStudio) Platinum Edition series provides
developers with a unified DSP platform development environment with
a collection of integrated tools designed to boost productivity and
reduce common debug frustrations. With powerful features for every
stage of the development process, the CCStudio Platinum enables
developers to meet their application performance and schedule goals
with easy-to-use, robust development tools and software.

eXpressDSP Real-Time Target-Side Software Saves
Valuable Time
• DSP/BIOS™ Kernel – a proven, scalable, real-time software kernel

including chip support libraries that create the foundation for software
development work, eliminating many low-level coding tasks and greatly
simplifying real-time task scheduling.

• TMS320™ DSP Algorithm Standard – an interoperability coding
standard that facilitates the reuse of software components from your
previous projects, other developers and outside sources.

• eXpressDSP Reference Frameworks – a set of open source, C-
based starterware templates optimized for multiple application param-
eters. Production-ready code, which is simple to modify, enables you to
be up and running very quickly.

World’s Largest DSP Third Party Network
• The TI DSP Third Party Network provides a rich library of TMS320

DSP-based software modules and host tool plug-ins that are easily
integrated to fit the needs of your application. This network also pro-
vides hardware platforms, emulators and consultant services.

CCStudio Platinum Highlights

End Debug Frustration and Stress

• Connect/Disconnect makes it easier to connect and disconnect with
the target dynamically. This new functionality provides robust and
resilient connection to the target board and even allows you to restore
the previous debug state when connecting again.

• Rewind Debugging saves developers from repeating tedious reload
and rerun sequences with a single keystroke backstep option to quickly
jump to the previous instruction in the source code.

• Unified Breakpoint Manager quickly organizes and manages both
software and hardware breakpoints from an easy-to-use interface.

Shorten Learning Curve and Simple Configuration Control

• CodeWright: Industry’s most familiar and popular editor now integrat-
ed with CCStudio shortens learning curve and offers rich editing
capabilities.

• Component manager: Simple configuration control of CCStudio com-
ponents allows developers to freeze or evaluate new versions of com-
pilers and DSP/BIOS kernel releases.

• CCStudio IDE: One look and feel for three DSP platforms eliminates
learning curve for evolving/expanding cross-platform DSP development.

Achieve Programming Goals in Less Time with Maximum
Results

• Application Code Tuning takes weeks out of the optimization
process with a collection of integrated tuning tools. CCStudio enables
developers to build applications faster and easier than ever before, uti-
lizing a “tuning approach” that allows full optimization of both the code
and the silicon.

• Tuning Dashboard provides the user with a single interface for man-
aging the optimization process. A user-defined Goals window allows
the user to setup optimization targets and track progress towards the
desired goals. The dashboard also contains a proactive Advice Window
that provides specific optimization suggestions and advice on which
tuning tools to use to achieve development goals. A Profile Setup and
Viewer feature manages and displays the data collected during
development.

• Compiler Consultant analyzes your application and makes recommen-
dations for efficient coding. Each time the application is compiled,
Compiler Consultant will examine the code and create suggestions for
different optimization techniques to improve code efficiency.

• CacheTune makes it easier to identify non-optimal cache usage by
graphically representing cache memory accesses. This visual/temporal
view of cache accesses enables quick identification of problem areas
(such as areas related  to conflict, capacity, or compulsory misses) to
help you greatly improve an application’s overall cache efficiency.

* All CCStudio features described may not be available for every supported TI processor.
Please check the Features by Platform support matrix for support details.

eXpressDSP™ Software and Development ToolseXpressDSP™ Software and Development Tools

For more information, visit www.ti.com



TI’s Development Tools and Software Available Throughout Design Cycle
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TI’s Development Tools and Software Available Throughout Design Cycle

• Host Tools
– Select target
– DSP/BIOS™ 

configuration
– Power Planning

The tight integration of Code Composer Studio™ (CCStudio) software with
eXpressDSP™ software and the TMS320 DSP, DaVinci™ and OMAP™ processors
speed your design through each stage of the design cycle. Take advantage of the
many features of eXpressDSP products to become more productive and accelerate
time-to-market.

• Target Software
– Reference Frameworks
– DSP/BIOS Kernel
– TMS320™ DSP Algorithm 

Standard

• Host Tools
– Project Manager
– Component Manager
– CodeWright Editor
– Code Generation
– Device & CPU Simulators

• Target Software
– Libraries
– Drivers

• Debug Host Tools
– Familiar debug interface
– Multi-processor support
– Data I/O visualization and Probe Points™
– Connect/Disconnect
– Rewind           –   Watch Windows and Symbol Browser

• Scripting Emulators
– XDS560™ Emulator
– XDS510™ Emulator

TI’s Third Parties are a valuable resource: In addition to eXpressDSP-compliant algo-
rithms, the TI DSP Third Party Network provides target boards, application starter kits,
consultant services, as well as software tools, Code Composer Studio IDE plug-ins
and additional hardware tools to help you through each stage of the design flow.

• Host Tools
– Profiler
– Power Analyzer
– Advanced Code

Tuning

• Target Software
– Real-time analysis
– RTDX™
– Power-Scaling Library

Application Design
Host Tools
Quickly setup and configure your
application with CCStudio setup. The
drag-and-drop configuration utility
enables you to quickly select and
setup hardware systems and initialize
the CCStudio environment. Even a sys-
tem with multiple boards and CPUs
can be configured in a few seconds.

Configure DSP/BIOS resources
during application design with the
DSP/BIOS configuration tool. Create
and configure DSP/BIOS objects used
by your program and eliminate
resource contention at this early stage.

Estimate and plan power con-
sumption early with device-specific
planning tools.
Target Software
Get started faster and eliminate many
low-level coding tasks up front by
using ready-to-go eXpressDSP
Software.

Jump start development with
eXpressDSP Reference Frameworks.
Choose the framework which best fits
your application: RF1 “Compact,” RF3
“Flexible” or RF5 “Extensive.” Built on
the foundation of DSP/BIOS™ Kernel
and the TMS320™ DSP Algorithm
Standard, this solid production-quality
base code can get your applications
off the ground quickly.

Get productive faster and elimi-
nate the need to design and validate
your own scheduler. Take advantage
of the industry-proven scalable
DSP/BIOS real-time kernel to perform
time scheduling and synchronization.
Use the built-in host-to-target
communications and real-time instru-
mentation for real-time analysis in
later stages of development. The ker-
nel includes pre-emptive multi-thread-
ing, hardware abstraction, real-time
analysis, configuration tools and chip
support libraries so you can spend
time on more innovative and produc-
tive activities.

Make, buy or reuse software.
Utilize the TMS320 DSP Algorithm
Standard to make your code reusable
and to take advantage of the rich
offering of eXpressDSP-compliant
algorithms ready to drop into your
application.

Code & Build
Host Tools
Manage your project effectively
using the visual Project Manager. It
provides fast access and manipulation
of single or multiple project files with
drag-and-drop as well as double-click
edit capabilities. The Project Manager
also can integrate with a number of
industry-standard source control sys-
tems, giving development teams bet-
ter control of their project.

Lock down compiler and/or
DSP/BIOS versions for the life of
the project. The component manager
lets developers freeze critical compo-
nents by project and continue to
upgrade the IDE. The flexibility of the
component manager allows
developers to easily evaluate new ver-
sions before committing to them in
their design.

Improve Code Integrity.
Integrated CodeWright editor includes
powerful editing features like
CodeSense to ensure code syntax and
parameters are written correctly. This
familiar and easy-to-use editor
includes many text processing capabil-
ities such as: file diffing and merging,
custom code templates, block indent-
ing, case conversion and comment
insertion.

Generate efficient DSP code.
CCStudio supports C/C++ and
Assembly language coding. TI’s com-
pile tools are co-developed with the
DSP architecture, offering you best-in-
class performance with industry-lead-
ing global view analysis and architec-
ture-specific optimizations that include
interactive profiling, tuning and
feedback.

Start software development ear-
lier using TI’s fast simulators to do
more coding and validation. Start
before your hardware system is ready.
A wide array of simulators provide
options to determine how much of the
device to simulate: CPU only, CPU and
memory or full device simulators.
Target Software
Chip support libraries and drivers
reduce the need  to open a data
book to correctly configure TMS320
DSP device peripherals.

Debug
Host Tools
Get productive immediately with
CCStudio’s integrated debugger. This
familiar easy-to-use interface has many
features you would expect in a tradi-
tional debugger as well as many DSP-
specific and multi-processor design
capabilities.

Control execution of your code
with software breakpoints or with
hardware and conditional breakpoints
which can evaluate a C expression, a
local variable or a CPU register loca-
tion. Use global breakpoints to synchro-
nize the debug of multiple processors
on a multi-processor system.

Input and output data on your tar-
get with Probe Points™ data break-
points to control when data displays
are updated. Use graph options to dis-
play data in useful formats such as
FFTs, eye diagrams, constellation plots
and images.

Dynamic Host-to-target connec-
tion enables developers to isolate
hardware/software real time issues.
Connect/Disconnect eliminates the
need for frequent reset and restart
sequences.

Step or run backwards to a previ-
ous point in execution. Rewind restores
the state of resources to help develop-
ers quickly narrow down code problems 
in a single keystroke.

Examine your data and program
during run-time with the watch window
or simply roll your cursor over a vari-
able in the editor to use the ToolTip
feature to see its value.

Navigate your code with
CCStudio’s symbol browser, which has
detailed knowledge of your application
and displays all associated files, func-
tions, global variables, types and labels
of a loaded COFF output file (*.out).

Automate repetitive tasks using
CCStudio Scripting and CCStudio GEL
language. Use familiar languages such
as Perl or Visual Basic to automate
debug, testing and validation of appli-
cations with CCStudio software.
Emulators
CCStudio supports XDS510 and
XDS560 class emulators. The XDS560
Emulator reaches real-time data rates
of over 2 MB/second on enabled high-
speed RTDX processors to provide an
unparalleled level of real-time debug.
The XDS560 Emulator is fully upward
compatible with TI’s XDS510 Emulator.

Analyze & Tune
Host Tools and Target Software
Get insight into your running applica-
tion and determine how to maximize
performance, minimize footprint, man-
age power consumption and/or make
your code more robust.

Examine operation of your
system in real time and find glitches
and bottlenecks that may only show up
in real-time operation. This is made
possible by the advanced RTDX and
DSP/BIOS technologies integrated with
CCStudio which allow you to get data
from your application while it runs in
real time.

Continuous visibility and
communication with your target
application without halting the proces-
sor using RTDX data transfers
between host and target. With real-
time data rates of over 2 MB/second,
some processors can transfer large
data files such as video images in real
time.

Analyze task interaction with
DSP/BIOS run-time services on your
running application to determine if
tasks are well integrated and if your
application is best utilizing resources.

Optimize power consumption for
power-sensitive applications. CCStudio’s
power analyzer and power-scaling
library allow developers to visualize
power consumption across the DSP, I/O
or system. Use the power-scaling
library to automatically scale the fre-
quency and voltage of power-hungry
functions, resulting in lower power
consumption for the full application.

Extract maximum performance
and full feature utilization from your
DSP system with a comprehensive
tool chain designed specifically to
optimize (or tune) your DSP system.

Tuning tools are used to improve
execution time, utilize cache more effi-
ciently and decrease memory usage.
These tools are wrapped with an
interactive advisor that walks the user
through the optimization process spe-
cific to the goals set by the developer.
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Code Composer Studio IDE

Key Benefits
• Quick start with familiar tools andinterfaces

• Easily manage large multi-user, multi-site and multi-processor projects

• Utilize fast code creation, optimization and debugging tools

• Maximize reuse and portability for faster code development

• Perform real-time analysis enabled by RTDX and DSP/BIOS technologies

Update Advisor
All CCStudio registered users with a current subscription have access to
CCStudio’s live update capability. The Update Advisor is a web-based
application designed to allow you to keep your system efficient and up-to-
date. The Update Advisor is aware of every CCStudio component installed
on your system, and it is able to compare this information with the avail-
able CCStudio updates. It then compiles a custom list of available, easy-to-
install system updates. This allows you to keep your system up-to-date
with the latest software from TI and also gives you access to valuable
resources on the web to cut your development time.

Code Composer Studio ™ Features and BenefitsCode Composer Studio ™ Features and Benefits

Resources for eXpressDSP™ Software and
Development Tools
Learn more about CCStudio and the eXpressDSP Software capability with
the online tutorial, multimedia demos and built-in context-sensitive help.
Go to CCStudio’s Help Menu to access these resources. In addition, there
are a number of other web-based resources available.

• DSP Information: www.ti.com/dsp
• eStore: www.ti.com/dspestore

• Technical Documentation: www.ti.com/dsp

• Knowledge Base: www.ti.com/dspkbase

• Online Training: www.ti.com/dsptraining

• One-Day Workshops: www.ti.com/1dayworkshops

• Multi-Day Workshops: www.ti.com/multidayworkshops

• Third Party Catalog: www.ti.com/thirdpartycatalog



Code Composer Studio IDE is accompanied by a complete documentation
set that includes online help, tutorials, reference guides, user’s guides, and
application reports.

From the Code Composer Studio Help Menu…

From the Menu Bar, choose Help →… Contents. The following dialog box
appears and provides access, through links, to the complete set of online
help topics and documentation:

Note: Viewing the Code Composer Studio IDE online manuals and
application notes requires Adobe Acrobat Reader. Adobe Acrobat Reader
7.0 is provided on the installation CD.

From the Start Menu…

You can also access the online help without opening Code Composer
Studio IDE by choosing

Start → All Programs → Texas Instruments → Code Composer Studio →
Documentation → [Platform] Help.

Online DocumentationOnline Documentation

Welcome to Code Composer Studio™ Version 3.3

What's New 
Read a brief summary (PDF) of new and different features in Code Composer Studio IDE 3.3.

User Manuals
View a list of all available user guides, reference manuals and application reports available for 
your target device (PDF format, installed locally). 

Tutorial
Learn how to begin developing DSP applications with Code Composer Studio™ IDE:

DSP Knowledgebase 
Search the latest FAQs, updates, bugs and troubleshooting online:

Multimedia Demos for Code Composer Studio IDE
Animated demo of how to perform basic IDE operations:

Release Notes
Read essential information about bug fixes and known problems associated with this release.

Product Registration, Technical Support Phone Numbers and TI Support Web Sites
Read about the range of services and support available to you as a TI customer.

TMS320™ DSP Algorithm Standard
Learn about a set of coding conventions and standards for developing third-party algorithms 
and incorporating other algorithms into your own product:

Where and How to Look for Information
A short guide about how to find the information you need in online help.

Places to Start: References 
Setting Default IDE Behaviors & Paths at Startup GEL Functions: Alphabetical List
Using the CodeWright Text Editor Keyboard Shortcuts
Working with Projects 
Debugger Basics

Welcome to Code Composer Studio™ IDE

For more information, visit www.ti.com

Code Composer Studio™ IDE – Quick Start Reference Guide



Installation Requirements
These operating platform requirements are necessary to install the Code
Composer Studio Integrated Development Environment (IDE):

Minimum
• 1-GHz CPU

• 512 MB of RAM

• 600 MB of free hard disk space

• 1024×768 display

• Internet Explorer™ 5.0 or later

• Local CD-ROM drive

Recommended
• 2-GHz CPU

• 2 GB of RAM

• 16-bit color

Supported Operating Systems
• Windows® 2000 Service Pack 4

• Windows XP Pro Service Pack 1 & 2

• Windows XP Home Service Pack 1 & 2

Installing Code Composer Studio IDE

Note: Before starting the Code Composer Studio IDE installation, be sure
that any antivirus software is disabled. You must install and run Code
Composer Studio IDE using administrator privileges. If installing hardware,
follow the instructions provided with the hardware.

1 Insert the installation CD into the CD-ROM drive.

An install screen should appear after a few seconds; if not, go to
Windows Explorer and run setup.exe from your CD-ROM.

2 Respond to the dialog boxes as the installation program runs. You can
customize the components that are installed.

Setting Up your Device Configuration
The first step in using Code Composer Studio IDE is to configure the target
board or simulator that you want to use.

To load a standard configuration file:

Invoke the setup application by double clicking on the Setup CCStudio icon
that appears on your desktop. The list of standard configurations is listed
in the center pane of the setup program.

1 Click on the Factory Boards tab located at the bottom of the center
pane. 
This will display a list of standard configurations provided by Texas
Instruments or installed third-party packages.

2 Select the appropriate board or simulator configuration. Use Filters to
help narrow the available choices, and either double click on the item,
drag the selected configuration to the left pane or click on the
configuration and hit the add button to add it to your system.

3 Repeat the step above for each board or simulator you wish to add to
your system. Your configuration may contain more than one target
board.

Within the setup interface, the configuration you selected is graphically
displayed under My System in the left pane.

If you select more than one target configuration in the setup, the
Parallel Debug Manager (PDM) will be launched when you start Code
Composer Studio IDE. The PDM lets you control multiple debug
sessions.

4 Click the button labeled Save and Quit. The configuration is saved in the
System Registry.

5 Click Yes to the question, “Start Code Composer Studio on Exit?” The
Setup utility is closed and Code Composer Studio IDE is started.

To set up a new system configuration:

If you have a custom board or you cannot find your board under the Factory
Boards you can create your own configuration.

1 Select the Create Board tab located at the bottom of the center pane.

2 Select the appropriate connection type (emulator or simulator). Double
click on it or hit Add to bring up the Connection Properties Connection
Properties dialog.

3 Fill in the properties for the connection and click Finish.

4 You will then be presented with a list of the supported processor types
in the center pane. Double click on the desired processor to bring up the
Device Properties dialog.

5 Fill in the properties for the device and click Finish. Repeat as
necessary.

6 Click the button labeled Save and Quit. The configuration is saved in the
System Registry.

7 Click Yes to the question, “Start Code Composer Studio on Exit?” The
Setup utility is closed and Code Composer Studio IDE is started.

For more information on setting up a new system configuration, see the
Code Composer Studio IDE Setup online help.

Quick Start GuideQuick Start Guide

Code Composer Studio™ IDE – Quick Start Reference Guide



Running the Code Composer Studio IDE Tutorial
The interactive Code Composer Studio IDE tutorial as well as the Code
Composer Studio IDE Getting Started Guide, provides an effective method
to learn about the new and existing features of this tool.

1 Code Composer Studio IDE should now be running. If it is not already
running, double-click on the CCStudio icon on your desktop.

2 From the Code Composer Studio IDE Help menu, select Tutorial.

Using Code Composer Studio IDE to Build a Program

To create a new project:
1 Select Project → New from the menu. This opens the Project Creation

dialog box. In the Project Name field, type the new project name.

2 In the Location field you can either type the name of the correct project
directory where you want the project to reside or you can browse to it
by clicking the … button.

3 In the Project Type field, select library or executable, depending on the
type of output you are creating.

4 In the Target field, select the target you have configured for Code
Composer Studio IDE and click Finish.

To open an existing project:

1 Select Project → Open from the menu. The Project Open dialog box
appears. Navigate to the correct project directory. Highlight the project
you want to use and choose Open.

Existing projects created under previous versions of Code Composer
Studio IDE will automatically be migrated to the latest format when
they are opened.

To add files to a project:

1 Select Project → Add Files to Project. In the Add Files to Project dialog
box, navigate to the appropriate location, select the file, and click Open.

Note: Code Generation Tools include runtime library files (e.g.,
rts6400.lib). The runtime libraries contain the Standard C Library of
functions. If you are going to be using Standard C Library functions, you
must add the target-specific runtime libraries to your project.
Do not try to specify include or header files directly. These files are
automatically added to the project by scanning the source files for
dependencies.

Building and running the program:

• Setting Build Options: Select Project → Build Options from the menu.
You can change options for the compiler and linker.

• Building the program: Choose Project → Rebuild All to re-compile,
re-assemble, and re-link all the files in the project. Messages about this
process are shown in a frame at the bottom of the window.

• Loading the program: Select File → Load Program to load the
executable file (*.out). Select the program you just rebuilt and click
Open.

• Running the program: Select Debug → Run.

Quick Start GuideQuick Start Guide

Code Composer Studio™ IDE – Quick Start Reference Guide

For more information, visit www.ti.com



What is DSP/BIOS Kernel?

DSP/BIOS is a scalable, real-time kernel that is designed for applications
that require real-time scheduling and synchronization, host-to-target com-
munication, or real-time instrumentation. 

The DSP/BIOS kernel is packaged as a set of modules that can be linked
into an application. It is integrated with Code Composer Studio™
Integrated Development Environment (IDE), requires no runtime license
fees, and is fully supported by Texas Instruments. The kernel is also a key
component of TI’s eXpressDSP™ technology.

DSP/BIOS kernel enables you to develop and deploy sophisticated applica-
tions and eliminates the need to develop and maintain custom operating
systems or control loops. Because multi-threading enables real-time appli-
cations to be cleanly partitioned, applications using DSP/BIOS kernel are
easier to maintain and new functions can be added without disrupting real-
time response. DSP/BIOS kernel provides standardized APIs across
TMS320C2000™, TMS320C5000™ and TMS320C6000™ DSP platforms to
support rapid application migration. Additionally, it includes configuration
support for EVMs, DSKs, simulators, and some third-party boards. Existing
configuration templates are easily adaptable to provide support for custom
boards and other third-party boards. 

DSP/BIOS kernel is integrated into the Code Composer Studio IDE. Code
Composer Studio’s kernel object viewer and real-time analysis provide a
powerful set of integrated tools specifically focused on debugging and tun-
ing multitasking applications.

DSP/BIOS Kernel Components

The DSP/BIOS kernel includes the following components:

• DSP/BIOS Configuration Tool. This tool allows you to create and
configure the DSP/BIOS kernel objects used by  your program. You can
use this tool to configure memory, thread priorities, and interrupt
handlers settings.
To open the DSP/BIOS Configuration Tool, choose File → New →
DSP/BIOS Configuration within Code Composer Studio IDE. Select the
template for your DSP target and click OK.
For help on the Configuration Tool, press F1 while the Configuration
Tool window is active.

• DSP/BIOS Real-Time Analysis Tools. These tools allow you to view
program activity in real time. For example, the Execution Graph shows a
diagram of thread activity.
To open a DSP/BIOS kernel analysis tool, use the DSP/BIOS kernel
menu or the Real-Time Analysis toolbar within Code Composer Studio
IDE.
For help on a DSP/BIOS kernel analysis tool, press F1 while the tool
window is active.

• DSP/BIOS Kernel. Your C, C++, and assembly language programs can
call over 150 DSP/BIOS  functions.
For reference information on DSP/BIOS kernel, choose 
Help → Contents and open the DSP/BIOS book in the Contents tab.

Code Composer Studio™ IDE – Quick Start Reference Guide
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Use this document: If you need this information: How to open it:
DSP/BIOS Tutorial How to get started with DSP/BIOS kernel and gain a hands-on

introduction to various modules.
Online Help: Within Code Composer Studio™, choose 
Help → Tutorial. Go to the Using DSP/BIOS section.

DSP/BIOS User’s Guide How DSP/BIOS works. This manual includes an overview of DSP/BIOS
and discusses the threading model, real-time analysis and instrumenta-
tion, memory management, and I/O.

Adobe Acrobat file: In Code Composer Studio, choose 
Help → User Manuals. In the web page that opens, follow the link
to open the DSP/BIOS User’s Guide.

DSP/BIOS API Reference Reference information about DSP/BIOS modules, objects, API functions,
device drivers, and utilities. This information is also provided in the
DSP/BIOS online help.

Adobe Acrobat file: In Code Composer Studio, choose 
Help → User Manuals. Follow the link to the DSP/BIOS API
Reference for your DSP platform.

DSP/BIOS Online Help Answers to questions about how to use DSP/BIOS; reference informa-
tion about DSP/BIOS modules, objects, API functions, device drivers, and
utilities; troubleshooting information.

Online help: Within Code Composer Studio, choose 
Help → Contents and open the DSP/BIOS book in the Contents
tab.

DSP/BIOS Website The DSP/BIOS area of the TI website includes links to application notes,
benchmarks, a discussion group, and training classes.

Website: On the Web go to www.ti.com/dsp and click on the
DSP/BIOS link in the eXpressDSP™ box.

Learning about DSP/BIOS™ Kernel
See the following documents and online locations for information about
DSP/BIOS kernel.



What is the TMS320 DSP Algorithm Standard?

The TMS320 DSP Algorithm Standard is a key ingredient of eXpressDSP™
Technology. It is a set of coding conventions for algorithm writers that ulti-
mately eliminates much of the time-consuming re-engineering work
required to integrate algorithms into a variety of applications. It achieves
this by defining common programming rules, guidelines, and interfaces. 

The TMS320 DSP Algorithm Standard enforces known behaviors, requires
documentation of features relevant to integration, and defines interfaces
for algorithms to use to request resources. As a result, the standard facili-
tates the integration and deployment of algorithms in a variety of systems.
Rules and guidelines are provided for the following DSP generations:

• TMS320C62x™/C64x™/C67x™/ DM64x™/DM644x

• TMS320C54x™/C55x™

• TMS320C24x™/C28x™

Utilizing the TI provided test tool, QualiTI, users can
test TMS320 algorithms for compliance with the
TMS320 DSP Algorithm Standard. Passing algorithms
are allowed to display and use the compliance logo
shown here. By using such algorithms, system integra-
tors can avoid bugs that result from unfounded assumptions by the algo-
rithm about resource availability and calling context.

The TMS320 DSP Algorithm Standard documentation, header files and
examples are included in Code Composer Studio. The full developers kit
may be downloaded from TI’s website.

To Create eXpressDSP-Compliant Algorithms

Download the TMS320 DSP Developer's Kit from www.ti.com/dsp.
Select Software DSP Algorithm Standard. Start by using the Hyperception
Component Wizard for step-by-step guidance to create a pre-built wrapper
that prevents the user from using non-conforming entries.

While adding your own unique IP, leverage the various documents listed
below to ensure compliance with the standard. Upon completion, verify
compliance with the standard by using the automated test tool – QualiTI.

To Use eXpressDSP-Compliant Algorithms

To browse and purchase off-the-shelf, production-ready algorithms, visit
TI’s web site to view a list of companies that have produced eXpressDSP
compliant algorithms. Go to the DSP Developers’ Village and follow the
links in the eXpressDSP Compliance Program box.

The following documentation, application notes and user’s guides are avail-
able to learn more about the TMS320 DSP Algorithm Standard.

Code Composer Studio™ IDE – Quick Start Reference Guide
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Use this document: If you need information about:
Design and Implementation of an eXpressDSP™-Compliant DMA Manager for C6x1x
(SPRA789)

Following an overview of DMA abstractions for eXpressDSP-compliant algorithms,
this application describes a C6x1x-optimized (C6211, C6711) ACPY2 library imple-
mentation and DMA Resource Manager, which can also be run on C64x™ devices.
An algorithm and example application is provided (including source code) to demon-
strate enhancements to DMA access.

DMA Guide for eXpressDSP-Compliant Algorithm Producers and Consumers
(SPRA445)

This application note provides an overview of the DMA architecture specified by the
TMS320 DSP Algorithm Standard. It also describes two sets of APIs used for access-
ing DMA resources: the IDMA2 abstract interface and the ACPY2 library.

Making DSP Algorithms Compliant with the TMS320 DSP Algorithm Standard
(SPRA579)

A tutorial on how to make an algorithm compliant to the standard.

The TMS320 DSP Algorithm Standard – a White Paper (SPRA581) A high-level overview of the algorithm standard.

TMS320 DSP Algorithm Standard API Reference (SPRU360) The formal API specification that algorithms must conform to in order to be compliant
to the standard.

TMS320 DSP Algorithm Standard Developer’s Guide (SPRU424) Implementing the TMS320 DSP Algorithm Standard interface.

TMS320 DSP Algorithm Standard Rules and Guidelines (SPRU352) The formal specification of the standard’s rules and guidelines plus overall descrip-
tions and explanations.

Using the TMS320 DSP Algorithm Standard in a Dynamic DSP System (SPRA580) Using standard algorithms in a system in which data objects are created and
destroyed over the life of the system.

Using the TMS320 DSP Algorithm Standard in a Static DSP System (SPRA577) Using standard algorithms in a system in which data objects are created at design
time.

Techniques for Implementing Shared Relocatable Buffers Using the TMS320 DSP
Algorithm Standard (SPRA790)

This application note presents several mechanisms supported by the TMS320 DSP
Algorithm Standard which can be employed by algorithm writers to assist application
developers in optimizing their system’s performance and sharing of memory
resources.



Enhance your knowledge and help get your customers to market easily and
quickly by leveraging TI DSP support. From your personal, online “24/7”
DSP KnowledgeBase to technical documentation, TI offers the fast and
accurate technical support you need when you need it. Online training,
webcasts, workshops and the TI Developer Conference provide an array of
convenient support choices.

TI DSP Online KnowledgeBase
The TI DSP KnowledgeBase is the industry’s most complete online resource
for DSP questions and project development support. Featuring an easy-to-
use, natural-language-based search capability, the DSP KnowledgeBase
pulls information from hundreds of thousands of TI DSP content Web
pages, including technical documentation. www.ti.com/kbase

Technical Documentation
Find complete and easy-to-use data sheets, user’s guides and application
reports for every TI DSP platform and corresponding DSP software develop-
ment tools. Easy navigation and search capabilities for more than 3,000
dedicated online DSP Web pages and more than 100,000 pages of DSP
technical documentation. Order your free technical documentation CD-ROM
today. www.ti.com/dsptechdocscd

Getting Started with TI DSP
TI’s web-based “Getting Started” DSP support tool helps engineers get
their designs from inspiration to implementation quickly and easily.
Designers choosing to use TI DSPs in their real-time applications get easy-
to-access introductory DSP content, thus decreasing the learning curve and
speeding products to market. www.ti.com/gettingstarted

The Essential Guide to Getting Started with DSP CD-ROM
This free CD contains links to a variety of getting started resources includ-
ing documentation and the latest new product information. It also provides
you a guided tour of the eXpressDSP™ Software and Development Tools.
Order your CD-ROM or download today. 
www.ti.com/getstartedcd

TI Product Information Center (PIC)
Worldwide technical support staff is available to answer questions and
troubleshoot problems. Contact the PIC by e-mail or directly by phone. 
www.ti.com/dspsupport

Publications

eTech Innovations eNewsletter
Receive the latest digital signal processing news from TI including: DSP sil-
icon, software, systems applications and support information. Subscribe
today for this free monthly eNewsletter.
www.ti.com/etechsubscribe

DSP Applications Journal
To support the design of specific DSP-based systems, view the online DSP
Applications Journal with the latest application notes by platform and
software.
www.ti.com/appsjournal

Embeddded Edge Online Magazine
The Embedded Edge online magazine offers comprehensive solutions, tips,
tricks and advice from people who have met and conquered some of the
development problems embedded developers face every day. Register
today to receive information on news, products and services and make your
life easier.
www.ti.com/embeddededge

TI DSP Training Options

TI Developer Conference
Worldwide
Create the Next Leading-Edge Signal Processing Design
The three-day TI Developer Conference provides networking opportunities
with industry and TI experts, must-have technical training and peer-to-peer
interaction for embedded designers. Tracks include: audio, communica-
tions, control, education, systems, tools, and video. For more information,
visit www.ti.com/tidc07

Europe
In one day, in one place, find the signal processing solution you need for
your application.
For more information, visit www.ti.com/tidc07

Asia
Get in-depth, technical information and interact with TI and industry
experts.
For more information, visit www.ti.com/tidc07

SupportSupport
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One-Day Workshops
One-day workshops are designed to offer product or technology knowledge
and more advanced information about a particular category of devices.
These workshops include a significant “hands-on” section and are ideal
introductions to get started with DSP. A list of available courses and sched-
ule information can be found at www.ti.com/1dayworkshops

Multi-Day Workshops
Multi-day workshops are for engineers who need to sharpen their design
and development skills. These workshops include significant “hands-on”
labs emphasizing the demonstration and application of techniques and
skills. TI workshops are highly beneficial in helping developers implement
their DSP designs quickly. A list of available courses and the schedule can
be found at www.ti.com/multidayworkshops

TI DSP Webcast Library
TI conducts free DSP webcasts to address topics most critical to designers.
A typical webcast includes a presentation followed  by a question &
answer session with the technical engineering presenter specializing in the
topic. After the live event, DSP webcasts are available via the archive
library. To access the library, visit www.ti.com/webcasts

DSP Third Party Network Overview
The TI DSP Third Party Network is a worldwide communi-
ty of respected companies offering products and services
that support TI DSPs. Products and services include a
broad range of end-equipment solutions, embedded soft-
ware, engineering services and development tools that help customers
accelerate development efforts and cut time-to-market. For more informa-
tion on the DSP Third Party Network, please visit www.ti.com/3p

Embedded software – eXpressDSP™ compliant algorithms and libraries
for a variety of applications such as voice, audio, video, imaging, telecom-
munications, speech, biometrics, encryption, motor control, as well as others.

Development Tools – Hardware and software tools including emulators,
device programmers, development boards, simulators, debuggers and
eXpressDSP-compliant plug-ins for Code Composer Studio integrated
development environment

End-Equipment Solutions – Third party developed designs for a variety
of end equipment solutions. These designs allow you to get a jump start on
your design while leveraging TI’s depth and breadth of products.

Engineering Services – Engineering services include turnkey designs,
hardware and software integration, training, research and development

TI DSP Third Party Support

Application Support
•  Products and services for

DaVinci™ technology
•  TI-developed digital media software

provided by Authorized Software
Providers (ASPs)

•  Hardware and reference designs
•  Modem and DSL, encryption, wireless,

voice and fax software
•  Real-time operating systems (RTOS)

Getting Started with DSP
•  On-site customized training
•  Contract engineering design resources
•  Subsystem development
•  Software experts in applications:

video and imaging, audio, embedded
control, telecom and biometrics

Comprehensive Development
Support
•  DSP boards, starter kits and

add-ons
•  Customized debuggers
•  Targeted development platforms
•  Real-time emulation
•  Consulting services
•  Simulation models

SupportSupport
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TI Worldwide Technical Support

Internet
TI Semiconductor Product Information Center
Home Page
support.ti.com

TI Semiconductor KnowledgeBase Home Page
support.ti.com/sc/knowledgebase

Product Information Centers
Americas
Phone +1(972) 644-5580
Fax +1(972) 927-6377
Internet/Email support.ti.com/sc/pic/americas.htm

Europe, Middle East, and Africa
Phone

Belgium (English) +32 (0) 27 45 54 32
Finland (English) +358 (0) 9 25173948
France +33 (0) 1 30 70 11 64
Germany +49 (0) 8161 80 33 11
Israel (English) 180 949 0107
Italy 800 79 11 37
Netherlands (English) +31 (0) 546 87 95 45
Russia +7 (4) 95 98 10 701
Spain +34 902 35 40 28
Sweden (English) +46 (0) 8587 555 22
United Kingdom +44 (0) 1604 66 33 99

Fax +(49) (0) 8161 80 2045
Internet support.ti.com/sc/pic/euro.htm

Japan
Fax International +81-3-3344-5317

Domestic 0120-81-0036

Internet/Email International support.ti.com/sc/pic/japan.htm
Domestic www.tij.co.jp/pic

Asia
Phone

International +886-2-23786800
Domestic Toll-Free Number

Australia 1-800-999-084
China 800-820-8682
Hong Kong 800-96-5941
India +91-80-41381665 (Toll)
Indonesia 001-803-8861-1006
Korea 080-551-2804
Malaysia 1-800-80-3973
New Zealand 0800-446-934
Philippines 1-800-765-7404
Singapore 800-886-1028
Taiwan 0800-006800
Thailand 001-800-886-0010

Fax +886-2-2378-6808
Email tiasia@ti.com or ti-china@ti.com
Internet support.ti.com/sc/pic/asia.htm
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Texas Instruments Incorporated and its subsidiaries (TI) reserve the right to make corrections, modifications, 
enhancements, improvements, and other changes to its products and services at any time and to 
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